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Introduction 
Polyphase signal generation is required for a broad range 
of test applications. For example, the power industry uses 
three-phase signals to assess the performance of 
equipment used in condition monitoring or fault detection 
systems. These tests require the simulation of three-phase 
sine waves with line frequencies, ranging from 50 - 800 
Hz, where fault conditions or high frequency noise are 
introduced. 
 
Three-phase AC power supplies may be considered for 
these polyphase applications. However, they are restricted 
by bandwidth limitations, the lack of independently 
controlled phases, high cost and the inability to recreate 
real-world waveforms as in reconstruction of fault 
conditions.  
 
Alternatively, arbitrary/function generators may be used.  
Their arbitrary waveform capability allows the digital 
reconstruction of virtually any wave type at frequencies 
much higher than programmable power supplies. This 
makes it possible to recreate high frequency fault 
conditions such as arcing, noise or voltage surges. 
Arbitrary/function generators cost much less than 
programmable power supplies and appear to be the clear 
choice for these applications. However, not all 
arbitrary/function generators are created the same. Some 
arbitrary/function generators lose phase accuracy when 
the frequency is adjusted. Others lack the resolution 
(waveform memory or clock speed) needed to accurately 
recreate a real-world signal.  
 
TEGAM’s 2700 series arbitrary/function generators 
address the synchronization, phase shift and resolution 
issues. Up to twenty channels of output may be accurately 
synchronized with the highest precision. The output 
frequency may be adjusted independently or dependently 
without the need to recalibrate phase offsets. TEGAM’s 
2700 series arbitrary/function generators offer up to 4 M 
of waveform memory and 50 MHz of bandwidth. 
 
The 2700 series arbitrary /function generators are ideal for 
simulating pulse, noise, sensor stimuli, speed profiles or 
faults. Unique events such as partial discharge, phase 
imbalance, drop outs, arcing or lightning surges may be 
digitally edited and downloaded into the 2700’s extended 
memory. Waveforms are created by using wave editing 
software, the unit’s front panel, or direct import from an 
oscilloscope. The outputs of the units are sufficient to 

drive high impedance loads such as inputs to data 
acquisition or other sensing devices. TEGAM offers a line 
of voltage or current amplifiers for applications where 
additional voltage or current is required. 
 

 
 
Figure 1 – TEGAM offers single or dual channel versions of 
arbitrary/function generators. Multiple generators may be 
synchronized to create up to 20 phase-calibrated outputs. 
 
Scope  
Our scope is to demonstrate the hardware and software 
configurations for creating a three-phase arbitrary signal 
using three TEGAM 2730 arbitrary/function generators. 
WaveWorks DDS, wave-editing software will be used to 
create sine waves for each of the phases. Noise will be 
superimposed onto one of the phases simulating a fault 
condition. The units are synchronized to each other using 
their programmable marker outputs. This configuration is 
not limited to three-phase sine waves. It extends to any 
application, which requires single to polyphase (up to 20 
channels) generation of low/high frequency arbitrary 
waveforms. 
 
Tools & Equipment 
3- TEGAM Model 2730, 125 MS/s arbitrary/function 
waveform generators (2725, 2730 or 2732 may be used) 
1- WaveWorks DDS Wave Creation Software (included 
accessory) 
1- P/N BNC-3285, BNC Tee Connector 
7- P/N CBL-3102, 3 ft BNC Cables 
3- P/N 1583-3, 3 ft GPIB cable (6 & 9 ft cables available) 
1- PC with GPIB capability (RS232 optional) 
1- Multi-channel Oscilloscope 
3- P/N 1000001, RS232 to USB Converter (Optional) 

Using Arbitrary/Function Generators to Simulate Polyphase Power Line 
Waveforms
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Instrument Setup and Initialization 
Three Model 2730, 125 MS/s arbitrary/function 
generators will be synchronized to simulate the polyphase 
sine waves. Designate each unit as being phase A, B, or 
C. Power each unit and press [SETUPS] > [F1-RECALL] 
> [0] > [ENTER]. This will return each of the units to its 
factory default settings. Next, verify that the memory 
protection feature is disabled so that new wave data may 
be written into memory. Press [WAVE] > [F5-ARB] > 
[F4-EDIT] > [F4-MORE] > [F3-PROT]. Verify that [F3: 
ALL] is highlighted. Make sure that [F4] is in the “OFF” 
condition. Repeat these steps for each unit. 
 
The TEGAM 2730 arbitrary/function generators have the 
capability to share a master clock between multiple units. 
Unit A will be configured as the master clock for units, B 
and C. In unit A, press the [PARAM] key and verify that 
[F5], the reference soft key is set to internal. This is 
verified by “INTCLK” being highlighted. Repeat these 
steps on the B and C units making sure that their 
reference inputs are set to “EXTCLK” and that the [F1: 
FREQ/RATE] is set to “RATE”. Units B and C will be 
designated as the slave units.  
 
Setting the Trigger Modes 
The 2730 may be run in continuous, triggered, gated or 
burst modes. The master unit or phase A unit will be run 
in continuous mode. Press the [MODE] key and select 
[F1-CONT]. Set Phases B and C to operate as slave units 
by pressing [MODE] > [F2: TRIG] > [F3: EXT]. External 
triggering causes the instrument to wait for an external 
signal at its TTL, trigger input. Because phase A is set to 
continuous trigger mode and phases B and C are set to 
external trigger, they will follow phase A with jitter free 
operation. 
 
Setting the GPIB Addresses 
The GPIB interfaces will be used to transfer the wave data 
from WaveWorks DDS to each of the instruments. Each 
instrument must be assigned a unique GPIB address. 
Press [UTIL] and make sure that “GPIB ACTIVE” is 
shown above the [F1] key. If it is not then press [F1] until 
“ACTIVE” appears. Adjust the dial or use the numerical 
keypad to enter a unique GPIB address for each of the 
phases and then press [ENTER] to store the new address. 
Repeat this process for each of the units. Note the 
addresses and their respective phases for future reference. 
 

Wiring and Configuration 
Unit A provides the master sample clock signal (REF 
OUT) to units B and C (REF IN). This configuration 
allows units A, B and C to share the same sample clock. 
Because A is the master, the sample rates of B and C will 
follow A. Refer to Figure 2 and connect the BNC cables 
for the clock references as shown. 
 
The fully programmable marker outputs are used to 
trigger the subsequent channel at a 120° phase shift. The 
position of the marker defines the phase offsets between 
A, B and C. The starting address and width of each 
marker output can be defined at any location within the 
instruments 4 mega points of waveform memory. Refer to 
Figure 1 and connect the BNC cables for the “MARKER 
OUT” and “TRIG IN” connections as shown. 
 
GPIB will be used as the primary communications 
interface. Connect the GPIB cable from the PC to the 
GPIB connector in the rear panel of the phase A, 2730 
unit. Piggyback the GPIB cables for B and C onto the A 
connector. Connect the oscilloscope to the bus if wave 
data will be uploaded into WaveWorks DDS. Use Figure 
2 as a reference for these connections. 

Figure 2 –Connection diagram for GPIB-driven polyphase 
operation. The 2700 series provides standard RS232 and GPIB 
interfaces. An optional RS232-to-USB converter is also 
available. 
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Loading and Sending the Wave Data 
WaveWorks DDS allows the simulation of partial 
discharge, phase imbalance, drop outs, arcing or lightning 
surges as used in testing fault detection equipment or 
other applications. This is achieved by enabling the user 
to create, edit, import or export wave data to TEGAM 
2700 arbitrary/function generators via RS-232 or GPIB 
interfaces. WaveWorks DDS is compatible with *.txt 
files, which may be imported from Excel, Matlab, 
Notepad or other versions of WaveWorks software. It also 
offers the direct import of wave data from popular Agilent 
and Tektronix oscilloscopes.  
 
Two sine waves will be created using WaveWorks DDS, 
one clean and the other with a noise spur. The clean sine 
wave shall be downloaded to phases A and C. The sine 
wave with the noise will be downloaded to phase B.  
 
Install and run WaveWorks DDS. Select Insert > Sine and 
a dialog box will appear. Set the starting point to 1, length 
to 1200, scale to 1.00 and the offset to 0.00 and press OK. 
A 1200-point sine wave should appear on your screen. 
 
Send the clean sine wave to phase A (GPIB addresses 16). 
By pressing File > Instruments > Model 2730.  Next, 
select Communication > Send Waveform > GPIB. A pop-
up window will appear allowing you to define the start 
point, data length and instrument address to send the wave 
data. Enter the required parameters into the dialog box. 
Refer to Table 1 for settings. Press “Send” and the data 
will download to the designated instrument. Repeat for 
phase C (address 18).  
NOTE: Waveforms will not appear at outputs B and C 
until the programmable markers on units A and B have 
been enabled. 
 

Instrument 
Settings 

Phase A 
Master Unit 

Phase B 
Slave 

Phase C 
Slave 

GPIB Address 16 17 18 
Wave Data Sine Wave Sine Wave 

with noise 
Sine Wave 

Marker 
Location 

400 400 0 

Data length 1200 1200 1200 
Starting 
Address 

1 1 1 

Reference 
Clock 

Internal External External 

Trigger Mode Continuous External External 
 
Table 1 – Instrument settings for polyphase operation. 

Next we will add a noise spur to the sine wave for phase 
B. Select Insert > Noise and a dialog box will appear. Set 
the starting point to 400, length to 50, scale to .20 and the 
offset to 0.00. Select “Add To Existing Waveform” then 
press OK. A 100-point noise spur will be superimposed 
between 90 and 180 degrees of the sine wave. Send this 
waveform to phase B (address 17).  
 
Using the Markers to Offset the Phases 
For this three–phase simulation, there must be a 120° 
offset between each of the channels. This can be done by 
either manually editing the waveforms or setting the 
location of the markers and triggering each channel.  
 
The marker’s address location, Y, is dependent upon the 
number of samples, Ns within a complete cycle of the 
waveform. The marker location, Y is determined for 
offsets less than 360° by the following formula: 
 

 
 

For wave data where one cycle contains 1,200 data points, 
the marker locations will be at address 400 for phase A 
and phase B. This will produce a 120° offset for each 
channel. Sometimes the division does not produce an 
exact integer value. In this case, the location of the marker 
must be rounded creating a slight phase error. This error 
can be avoided by creating a numerator that is exactly 
divisible by 360°. 
 
To program the markers so that each channel will be 
offset by exactly 120° we start with unit A. Press 
[WAVE] > [F5-ARB] > [MARK] > [F2-ADDR] > 
[4][0][0] > [ENTER]. Then enable the marker by pressing 
[F4-ON/OFF] until the “ON” condition is highlighted. 
This will produce a marker at phase A’s output to trigger 
phase B at 120°. Repeat this procedure for phase B to 
trigger phase C. There is no marker output required for 
phase C. 
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Figure 3 – Three phase sine wave data plotted in an Excel 
spreadsheet. 
 
Enabling and Verifying the Outputs 
Enable each of the arbitrary/function generator outputs by 
pressing the OUTPUT [ON] key until an “Out ON” 
message appears in the upper right hand corner of each 
LCD. Make sure the oscilloscope is set to a 50 Ω input 
impedance. Connect each channel to its respective phase 
output. Measure the phase offsets between each channel 
to confirm proper triggering and marker positions. 
Change the sample clock of the master unit. Phases B and 
C should follow. You should now have a three-phase, 
variable-frequency, sine wave (arbitrary signal) source. 
 
To set the output frequency, the clock rate of the master 
unit A needs to be determined by using the following 
formula: 

 
Where Clock Rate is the sample clock setting in samples 
per second, Fout is the desired frequency in Hertz, and Ns 
is the number of samples used for each waveform cycle. 
Because the slave units are configured to follow the 
master clock only phase A needs to be changed to adjust 
the output frequency. In this example, we have 1,200 data 
points for each complete cycle of sine wave. If the desired 
frequency is 400 HZ then the required sample rate is 400 
X 1,200 or 480 S/s. Making sure that each unit is in the 
arbitrary waveform mode, set the master A clock to this 
value by pressing [PARAM] > [F1: FREQ] > [4][8][0] > 
[KHz] and confirm the change in output frequency for 
channels A, B, and C. 

Determining the Final Amplitude 
The output amplitude is determined by the product of the 
DAC output times the amplitude setting. In WaveWorks 
DDS, the sine wave scale was set to 1.00, which produces 
exactly the amplitude setting. The scale of the noise was 
set to .2, so its p-p value will result in the product of .2 X 
the amplitude setting. 
 
Conclusion 
Arbitrary/function generators are highly versatile 
instruments with the capability to replicate just about any 
type of waveform. A polyphase configuration extends the 
usability of these generators beyond applications 
traditionally addressed by three phase power supplies. 
TEGAM’s 2700 series arbitrary/function generators offer 
higher bandwidth, waveform precision, phase accuracy 
and flexibility at a lower cost. Contact a TEGAM 
representative to learn more about how we can resolve 
your signal generation needs with our high performance 
test and measurement solutions.  
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